0%

pat-Ranking

排名问题(同分数排名处理)

问题重述

问题描述

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

问题分析

成绩排名问题,难点有两方面:

  1. 同分排名问题
  2. 地区排名问题

解决方法

排序之后,设置一个变量用于记录已统计的个数,如果当前人的分数和上一个相同排名就和前一个相同,否则按照排名来。
地区排名可以理解为分部分排名,可以用数组记录每个地区已经排了多少人了,进而确定当前的排名,但也要注意同分问题。

代码

#include <bits/stdc++.h>
using namespace std;
struct node
{
string id;
int s;
int l;
int r1;
int r2;
node()
{
r1 = 1;
r2 = 1;
}
};
bool cmp(node a, node b)
{
if (a.s != b.s)
{
return a.s > b.s;
}
else
{
return a.id < b.id;
}
}
int main()
{
vector<node> v;
int n, m,num=0;
cin >> m;
for (int i = 1; i <= m; i++)
{
cin >> n;
num+=n;
for (int j = 0; j < n; j++)
{
node temp;
cin >> temp.id >> temp.s;
temp.l = i;
v.push_back(temp);
}
}
sort(v.begin(), v.end(), cmp);
int rank = 1;
int lr[m + 1];
int lp[m + 1];
for (int i = 1; i <= m; i++)
{
lr[i] = 1;
lp[i] = -1;
}
cout<<num<<endl;
for (int i = 0; i < v.size(); i++)
{
int r1, r2, np;
np = v[i].l;
if (i > 0 && v[i].s == v[i - 1].s)
{
r1 = v[i - 1].r1;
v[i].r1 = r1;
}
else
{
v[i].r1 = rank;
r1 = rank;
}
rank++;
if (lp[np] != -1 && v[lp[np]].s == v[i].s)
{
r2 = v[lp[np]].r2;
v[i].r2 = r2;
}
else
{
r2 = lr[np];
v[i].r2 = r2;
}
lr[np]++;
lp[np] = i;
cout << v[i].id << ' ' << r1 << ' ' << v[i].l << ' ' << r2;
if (i != v.size() - 1)
{
cout << endl;
}
}
}